If your website runs PHP, there is an important security update to check. PHP, short for PHP: Hypertext Preprocessor, is programming software that runs on a web server and powers many websites behind the scenes. The PHP project, the group that maintains PHP, has announced two critical flaws known as php2shell. They can let a remote attacker make a vulnerable web server run commands without logging in.
Here is the simple version of how one attack path works. A specially formed upload request reaches a flaw while PHP is handling the request. On one demonstrated server setup, the flaw can be triggered before the website’s own code gets a chance to run its usual checks. It is a bit like a delivery being let into a building before reception has checked it. The PHP team says the risk is highest on that particular setup, but recommends that all PHP installations serving websites are updated. The issue is in the server software, not automatically in the words on your website, its theme or its WordPress version.
That is serious, but it does not mean every small business site has been hacked. The National Cyber Security Centre (NCSC), the UK authority for cyber security, urges organisations to take immediate action because the flaws could allow attackers to run commands on web servers running PHP. The Cybersecurity Service for the European Union institutions, also known as CERT-EU, says early demonstrations of the flaws have started to circulate. A demonstration is not proof that attacks have succeeded, but it makes a prompt check sensible. At the time of its alert, the US Cybersecurity and Infrastructure Security Agency (CISA), the US government body responsible for cyber security guidance, said it had not observed exploitation. The practical next step is to ask whoever runs your hosting to confirm the fix is in place.
What to ask
You do not need to change server settings yourself. Contact your web host, managed website provider or the person who looks after the site. You could send this:
“Could you confirm whether the PHP server running my website was affected by CVE-2026-109618 or CVE-2026-109619, and whether the security fix has been applied? Please tell me the PHP version or vendor security update now in use, and whether I need to do anything.”
The PHP project lists fixed versions as 8.2.35, 8.3.36, 8.4.27 and 8.5.12. If you use WordPress, the number shown for WordPress itself is different from the PHP version. Some hosting companies use their own package numbers, so ask them to confirm that their package includes the fix rather than relying on a number alone.
If you have a WordPress site
You can check the PHP version without changing anything. In your WordPress dashboard, go to Tools, then Site Health, choose the Info tab, open Server and look for PHP version. If you are not comfortable doing that, ask your website person to check it for you.
If the version is one of the fixed releases above, that is a good sign. If it is older, that does not by itself tell you whether your host has applied a backported fix. Ask the host to confirm. PHP 8.1 and older are no longer supported by the PHP project, although some hosting companies and software vendors may provide their own security fixes. Ask whether the version is patched and what their plan is for moving you to a supported release.
If your site is on a managed platform
If your site is built and hosted entirely on a managed platform such as WordPress.com, Wix or Squarespace, the provider looks after the server software, so you usually will not update PHP yourself. Ask the provider to confirm this security fix has been applied and whether you need to do anything.
Check where your site is actually hosted. Sometimes a website uses a separate host, or one part of it runs on another server. In that case, ask the company responsible for that server too. Wix sites do not run PHP directly, but if you use a separate server or custom service alongside Wix, ask whoever runs that part.
If you manage the hosting yourself, or do not know who does
If you rent web hosting or a shared server and manage it yourself, contact the host promptly and ask them to update the PHP package or confirm that an equivalent security patch is installed. Do not copy server commands from a social post or change settings you do not understand. An incomplete temporary measure is not the same as installing the fix.
If you are unsure who hosts the site, check the hosting bill, your domain or website account, or old emails from the person who built it. Your domain registrar may not be the company hosting the website. If no one is looking after the site, find a reputable web developer or managed hosting provider and ask them to identify the host, check PHP, apply the security fix and confirm what they changed.
The main thing is to get a clear answer from whoever runs the server. If you manage your own WordPress site and want help understanding the version number, send me a message and I can point you in the right direction.
Featured image: Brett Sayles on Pexels




